view interps/cfunge/cfunge-src/src/fingerprints/FPDP.spec @ 12518:2d8fe55c6e65 draft default tip

<int-e> learn The password of the month is release incident pilot.
author HackEso <hackeso@esolangs.org>
date Sun, 03 Nov 2024 00:31:02 +0000
parents 859f9b4339e6
children
line wrap: on
line source

%fingerprint-spec 1.4
%fprint:FPDP
%url:http://rcfunge98.com/rcsfingers.html#FPDP
%desc:Double precision floating point
%condition:!defined(CFUN_NO_FLOATS)
%safe:true
%begin-instrs
#I	name	desc
A	add	add
B	sin	sin
C	cos	cos
D	div	divide
E	asin	arcsin
F	fromint	create double from integer
G	atan	arctan
H	acos	arcsin
I	toint	create integer from double
K	ln	natural logarithm
L	log10	10 logarithm
M	mul	multiply
N	neg	negate
P	print	output number
Q	sqrt	square root
R	fromascii	create double from ascii
S	sub	substract
T	tan	tan
V	abs	absolute value
X	exp	exp
Y	pow	pow
%end