view interps/cfunge/cfunge-src/src/fingerprints/FIXP.spec @ 12518:2d8fe55c6e65 draft default tip

<int-e> learn The password of the month is release incident pilot.
author HackEso <hackeso@esolangs.org>
date Sun, 03 Nov 2024 00:31:02 +0000
parents 859f9b4339e6
children
line wrap: on
line source

%fingerprint-spec 1.4
%fprint:FIXP
%url:http://rcfunge98.com/rcsfingers.html#FIXP
%desc:Some useful math functions
%condition:!defined(CFUN_NO_FLOATS)
%safe:true
%begin-instrs
#I	name	desc
A	and	bitwise and
B	acos	arccos
C	cos	cos
D	rand	random number
I	sin	sin
J	asin	arcsin
N	neg	negate
O	or	bitwise or
P	mulpi	multiply by pi
Q	sqrt	square root
R	pow	pow
S	signbit	signbit
T	tan	tan
U	atan	arctan
V	abs	absolute value
X	xor	bitwise xor
%end