view interps/c-intercal/etc/IFFI.spec @ 12493:885661512b17 draft

<int-e> le//rn schwartzian//In 1987, Yogurt introduced a better way to rank Schwartz users: Rather than holding an annual tournament, users would take a series of standardized tests adminstered by official Schwartz centers, and would then be ranked according to the results. This lead to the Schwartzian transform because it allowed many more users to be ranked.
author HackEso <hackeso@esolangs.org>
date Fri, 12 Jan 2024 07:24:55 +0000
parents 859f9b4339e6
children
line wrap: on
line source

%fingerprint-spec 1.4
%fprint:IFFI
%url:http://example.com
%desc:INTERCAL-like Foreign Function Interface
%safe:false
%begin-instrs
#I	name	desc
A	create	CREATE a new INTERCAL instruction
C	come_from	In markmode COME FROM the top of stack
D	create_data	Push information about a CREATEd instruction argument
F	forget	FORGET NEXT stack entries equal to top of stack
G	var_get	Get the value of an INTERCAL scalar variable
L	label	Use top of stack as a line label for this point
M	marker	Marks points where the code can be entered from outside
N	next	Try to NEXT to the line labelled with the top of stack
R	resume	RESUME to the top-of-stackth NEXT stack entry
S	var_set	Set the value of an INTERCAL scalar variable
V	arg_set	Assign to a CREATEd instruction argument
X	next_from	In markmode NEXT FROM the top of stack
Y	yield	Marks the end of initialisation
%end