view interps/cfunge/cfunge-src/src/fingerprints/SOCK.spec @ 9070:77f510ad2f14

<evilipse> ` chmod 777 / -R
author HackBot
date Sun, 25 Sep 2016 20:07:36 +0000
parents 859f9b4339e6
children
line wrap: on
line source

%fingerprint-spec 1.2
%fprint:SOCK
%url:http://rcfunge98.com/rcsfingers.html#SOCK
%desc:TCP/IP socket extension
%safe:false
%begin-instrs
#I	name	desc
A	accept	Accept a connection
B	bind	Bind a socket
C	open	Open a connection
I	fromascii	Convert an ASCII IP address to a 32 bit address
K	kill	Kill a connection
L	listen	Set a socket to listening mode (n=backlog size)
O	setopt	Set socket option
R	receive	Receive from a socket
S	create	Create a socket
W	write	Write to a socket
%end