view interps/cfunge/cfunge-src/src/fingerprints/STRN.spec @ 9071:581584df6d82

<fizzie> revert 942e964c81c1
author HackBot
date Sun, 25 Sep 2016 20:17:31 +0000
parents 859f9b4339e6
children
line wrap: on
line source

%fingerprint-spec 1.2
%fprint:STRN
%url:http://rcfunge98.com/rcsfingers.html
%desc:String functions
%safe:true
%begin-instrs
#I	name	desc
A	append	Append bottom string to upper string
C	compare	Compare strings
D	display	Display a string
F	search	Search for bottom string in upper string
G	get	Get string from specified position
I	input	Input a string
L	left	Leftmost n characters of string
M	slice	n characters starting at position s
N	length	Get length of string
P	put	Put string at specified position
R	right	Rightmost n characters of string
S	itoa	String representation of a number
V	atoi	Retrieve value from string
%end