diff interps/egobf/configure.ac @ 996:859f9b4339e6

<Gregor> tar xf egobot.tar.xz
author HackBot
date Sun, 09 Dec 2012 19:30:08 +0000
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/interps/egobf/configure.ac	Sun Dec 09 19:30:08 2012 +0000
@@ -0,0 +1,32 @@
+#                                               -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.5)
+AC_INIT([egobfi], [0.7], [])
+AC_CONFIG_AUX_DIR([scripts])
+AM_INIT_AUTOMAKE()
+AC_CONFIG_SRCDIR([src/egobfi.h])
+AC_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stdint.h stdlib.h string.h wchar.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_TYPE([uint64_t], [INT64=true], [INT64=false], [#include <stdint.h>])
+AM_CONDITIONAL([USE_INT64], test "x$INT64" = "xtrue")
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([memset])
+
+AC_CONFIG_FILES([Makefile
+                 src/Makefile
+                 src/egobfi-wib])
+AC_OUTPUT